Board loading issue
      
Minor incident
      
        Zenhub
    
    
      
2024-02-21 20:36 UTC
      
      · 1 hour, 40 minutes
    
  Updates
          Resolved
        
        
February 21, 2024 · 22:15 UTC
        
      
      A fix for the board loading errors has been deployed and all services are back online. Should you encounter any further issues or have any questions, please do not hesitate to reach out to us at support@zenhub.com.
          Investigating
        
        
February 21, 2024 · 20:36 UTC
        
      
  The team is investigating issues with Boards, where some users may experience it not loading. Apologies for the inconvenience and thank you for your patience.
← Back
.png?v=63858746616) Zenhub Status
            
Zenhub Status