Zenhub Issue creation not working

Minor incident Zenhub
2025-04-05 19:00 UTC · 1 day, 22 hours, 2 minutes

Updates

Resolved

The issue should be fixed now.

April 7, 2025 · 17:02 UTC
Investigating

Some users have reported creating Zenhub Issues is not working. We are investigating…

April 7, 2025 · 16:12 UTC

← Back