Slow performance and delayed updates

Minor incident Zenhub
2025-04-28 20:00 UTC · 1 hour

Updates

Resolved

The issue has been resolved.

April 28, 2025 · 21:00 UTC
Issue

We’re seeing delays in processing updates from GitHub. Changes made to issues in GitHub may not appear in Zenhub right away. We’re investigating the problem.

April 28, 2025 · 20:26 UTC

← Back