Slow performance and delayed updates

Minor incident Zenhub
2025-04-29 18:15 UTC · 4 hours, 45 minutes

Updates

Resolved

The issue has been resolved.

April 29, 2025 · 23:00 UTC
Monitoring

The issue has been mostly resolved. Our team is still actively monitoring.

April 29, 2025 · 22:47 UTC
Investigating

The team is still working on addressing the problem. Your Zenhub workspace may be failing to load periodically. Please retry again. We will update here once the issue is fully addressed.

April 29, 2025 · 21:32 UTC
Investigating

We’re seeing delays in processing updates from GitHub. Changes made to issues in GitHub may not appear in Zenhub right away. We’re investigating the problem.

April 29, 2025 · 19:50 UTC

← Back