Users are unable to load Zenhub

Major incident Zenhub
2025-07-17 20:54 UTC · 46 minutes

Updates

Resolved

Issue resolved

July 17, 2025 · 21:40 UTC
Issue

The team is investigating reports that the Zenhub application is not loading for some users. We have confirmed the issue and the technical team is actively looking into the problem.

July 17, 2025 · 20:54 UTC

← Back