Zenhub is not accessible

Major incident Zenhub
2025-09-09 19:15 UTC · 1 hour, 10 minutes

Updates

Resolved

The issue has been resolved.

September 9, 2025 · 20:25 UTC
Monitoring

The application is back online. The team is investigating root causes and continuing to monitor for further issues.

September 9, 2025 · 19:25 UTC
Issue

The Zenhub application is failing to load, leading to a blank page. We’re investigating…

September 9, 2025 · 19:15 UTC

← Back