Zenhub Unreachable

Major incident Zenhub
2025-09-24 10:50 UTC · 3 hours, 24 minutes

Updates

Resolved

The issue is now resolved and the team is continuing to monitor.

September 24, 2025 · 14:13 UTC
Monitoring

The problem has been identified and resolved. The team is monitoring to ensure the services are operating as normal.

September 24, 2025 · 14:05 UTC
Issue

The Zenhub team is investigating reports of degraded performance and inability to load the Zenhub application.

September 24, 2025 · 13:50 UTC

← Back