Zenhub outage

Major incident Zenhub
2025-11-13 18:04 UTC · 2 minutes

Updates

Resolved

Zenhub should be back online

November 13, 2025 · 18:06 UTC
Issue

The Zenhub application is failing to load. We are aware of the issue and are working on a fix. ETA 5 minutes.

November 13, 2025 · 18:04 UTC

← Back