Zenhub is not accessible
Major incident
Zenhub
2025-11-25 17:33 UTC
· 34 minutes
Updates
Resolved
November 25, 2025 · 18:06 UTC
Zenhub is operating normally. All services are functioning as expected.
Investigating
November 25, 2025 · 17:53 UTC
We have detected performance issues and we are currently investigating.
← Back
Zenhub Status